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Introduction
The USB Development System Software is designed to be used with the USB Development Board to assist the users
of Cypress USB IC’s.  The System Software provides users with a means of developing and debugging their own
firmware.

The System Software provides an interface which opens up the access to various components on the Development
Board, such as the Program ROM, Data RAM, I/O Space, and Registers.  It also provides break point capability as
well as user code download capability and list file trace tracking.

General
The USB Development System Software is a Windows 3.1/Windows 95 application.

Minimum System Requirements
• A 80486 or Higher personal computer.
• At least 8MB of RAM.
• At least 10MB of free Hard Disk space.
• Microsoft Windows version 3.1 or Windows 95.
• A 3.5-inch (1.44-MB) high-density floppy disk drive.

Software Installation (Win 3.1 & Windows 95)
In Windows 3.1, select the “File => Run” function in the Program Manager and type A:\SETUP.EXE and press
<Enter> (where “A:” is the appropriate floppy disk drive).

OR

In Windows 95, select “Run” from the “Start Menu” and type A:\SETUP.EXE and press <Enter> (where “A”: is the
appropriate floppy disk drive.

Follow the installation instruction in the setup program.

The installation program creates a USB Monitor Icon ,“CM8MONxx” in the “CM8MONxx” Program Group where
“xx” is the system software version number.
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The USB Monitor/Debug Software

Getting Started
The USB Development System Software can be run by double clicking on the USB Monitor Icon.  Communications
can be established by setting the COM Port to the same RS-232 port that connects to the Development Board.  Once
the Development Board is connected and the software has loaded, the system software can download information to
the board or read information from it, or control the operation of the Development Board.

Program Organization
The USB Development System Software provides two types of control for the system.  The main menu is a typical
Windows pull down menu.  In addition to the main menu there is also a number of windows and buttons to control
program functions.  Figure 1 shows a view of the System Software when it is first started.  The Data RAM,
Registers/Flags, View, System Status, and List File window panes are the only window panes initially showing after
start up.  The Program RAM, I/O Space, Breakpoint and Download Object File window panes can be displayed by
using the View window buttons or menu (Download Object File is not available in the View menu).

Figure 1
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Windows and Button Controls
The I/O Space, Data RAM, Program RAM, List File, Breakpoint and Download Object window panes are re-sizable
and can be moved to any location.  The View, Registers/Flags, and System Status window panes are not re-sizable
but can be moved to any location within the main window.

View Button Window
The View Button Window contains “buttons” which control the display of windows inside
the main program window.  Clicking on the buttons will open or close the particular
window panes.

I/O Space Button: Open/Close the I/O Space window.

Data RAM Button: Open/Close the Data RAM window.

Program RAM Button: Open/Close the Program RAM window.

List File Button: Open/Close the List File window.

Registers Button: Open/Close the Registers/Flags window.

Status Button: Open/Close the System Status window.

Bkpt(s) Button: Open/Close the Breakpoints window.

Dnld Object Button: Open/Close the Download Object File window.

I/O Space Window
The I/O Space window provides the functions of
displaying and altering the contents of the I/O Space
addresses.  Four buttons are provided for changing the
contents of the I/O Space; Wr_Sel, Wr_All, Rd_Sel,
Rd_All.

“Wr_Sel” will WRITE the highlighted address of the
I/O Space with the contents of the data input box.  The
data input box is located above the data display
window.  “Wr_All” will WRITE the contents of the
data input box to the entire I/O Space.  Click on the data
input box or use “Shift-Enter” to input data in the input
box.  The data format can be changed to hexadecimal or
binary form by clicking on the Data Display Format
choices of “Hex” or “Binary”.

“Rd_Sel” will READ the highlighted address of the I/O
Space.  “Rd_All” will READ the entire contents of the
I/O Space.  Use the scroll bar to scroll through all of the
available I/O Space addresses.



5

Data RAM Window
The Data RAM window provides the functions of
displaying and altering the contents of the Data
RAM.  Four buttons are provided for changing the
contents of the Data RAM; Wr_Sel, Wr_All, Rd_Sel,
Rd_All.

“Wr_Sel” will WRITE the highlighted address of
the Data RAM with the contents of the data input
box.  The data input box is located above the data
display window.  “Wr_All” will WRITE the
contents of the data input box to the entire Data
RAM.  Click on the data input box or use “Shift-
Enter” to input data in the input box.

“Rd_Sel” will READ the highlighted address of the
Data RAM.  “Rd_All” will READ the entire
contents of the Data RAM.  Use the scroll bar to
scroll through all available Data RAM locations.

Program RAM Window
The Program RAM window provides the functions
of displaying and altering the contents of the
Program RAM.  Four buttons are provided for
changing the contents of the Program RAM;
Wr_Sel, Wr_All, Rd_Sel, Rd_All.

“Wr_Sel” will WRITE the highlighted address of
the Program RAM with the contents of the data
input box.  The data input box is located above the
data display window.  “Wr_All” will WRITE the
contents of the data input box to the entire Program
RAM.  Click on the data input box or use “Shift-
Enter” to input data in the input box.

“Rd_Sel” will READ the highlighted address of the
Program RAM.  “Rd_All” will READ the entire
contents of the Program RAM. Use the scroll bar to
scroll through all available Program RAM locations.
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List File Window

The List File window displays the current list file which has been loaded.  The list file can be loaded by using the
File menu (the operation of the File menu is described in section 5.1) or by clicking on the “Load List File After
Download” in the Download Object File Window (see Download Object File Window in section 4.9).  Scrolling
through the list file can be accomplished by using the scroll bar, arrow keys or “PgUp/PgDn” keys.  By “double
clicking” on a line in the list file window, a break point can be set or removed.  Whenever the state of the
development board toggles from a “Running” state to the “Stopped” state the “highlighted” line in the list file will
reflect the current Program Counter contents.

Registers/Flags Window
The Register/Flags window displays the current values of the microcontroller registers and flags.  The window will
update any time the Development Board toggles from a “Running” state to the
“Stopped” state or when the “Get Watch” button is clicked in the System Status
window.  The contents of the registers or flags can be changed by clicking in
any of the display boxes, changing the contents, and pressing <Enter> or
<Return>.

System Status Window
The System Status window displays the current “Running” or “Stopped” status
of the Development Board.  This window also has four buttons which controls
the run status of the Development Board.  Run will put the Development Board
into “run” state.  Break will cause the Development Board to stop executing.
Single Step will single step the Development Board one instruction at a time.
Get Watch will update the Registers/Flags window and the selected address in
the Data RAM and I/O Space windows.  Get Watch can be turned on by
clicking on the “watch on” box.  A check mark in the box indicates that Get
Watch is on, no check mark indicates it is off.  Step Over executes an entire
routine of a call instruction and then stops at the next address.  Selecting any of
these buttons (except Run) causes updates to the Registers/Flags windows, and
any highlighted fields in the Data RAM and I/O Space windows (depending on
the preference settings, see section 5.4).
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Breakpoints Window
The Breakpoints window displays the current breakpoints as well as providing the ability to Add, Delete, and Toggle
breakpoints.  The “Add” button adds whatever address has been
inputted into the “New Breakpoint Address” data input box.  The
“Delete” button will delete whatever breakpoint is currently
highlighted.  The “On/Off” button will toggle the highlighted
breakpoint on and off.  In order to use breakpoints, the Development
Board must be running from “Program RAM” (see the USB
Development System User’s Guide).

Download Object File Window
The Download Object File window provides the function of downloading an object file to the “Program RAM”.  The
“download” button downloads the object
file.  The object file is a “*.rom” file output
by the assembler.  This file can be tested
once it is downloaded to the “Program
RAM”.  The “cancel” button cancels the
downloading process.  Clicking on the
“Load List File After Download” box will
automatically display the list file when an
object file is loaded.  A check mark in the
box indicates that “Load List File After
Download” is on, no check mark indicates
it is off.  A “checksum” is available to
ensure that the contents of the object file
are correct.  This value should match the
checksum in the list file.  To download an
object file, the Development Board must be
running from “Program RAM” (see the
USB Development System Users Guide).
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Main Menu

File Menu
The File Menu contains only file functions associated with the “List File” and “Program RAM” windows.

Load List File: Load a selected List File (*.lst) into the “List File Window”.  A List File is the listing file
from the assembler displaying the program address listing of the assembled program.

Unload List File: Unload the currently loaded from the “List File Window”.  After this operation the “List
File Window” will be empty.

Download Object File: Download an Object File to the “Program RAM”.  The Object File is a “*.rom” file
output by the assembler.  When this file is downloaded to the “Program RAM” it can be
tested.  The board must be properly configured to load the Program RAM; see the USB
Development System User’s Guide.

Load Project: Loads a project (setups, settings of windows and directory being used).
Save Project: Saves the current project.
Save Project As: Saves the current project with a new name.
Exit: Close the USB Development System Software application.

View Menu
The View Menu contains the selections for opening and closing all of the program window objects in the main
program window, except the Download Object File Window.  Selecting an item is the same as clicking on a button in
the View window (see Section 4.1) except the View Menu contains an additional selection, “View Bar” as shown
below.

Data Ram: Open/Close the Data RAM window.
I/O Space: Open/Close the I/O Space window.
List File: Open/Close the List File window.
Breakpoints: Open/Close the Breakpoints window.
View Bar: Open/Close the View Bar window.
Registers/Flags: Open/Close the Register/Flags window.
System Status: Open/Close the System Status windows.
Program RAM: Open/Close the Program RAM window.

System Menu
The System Menu controls the “Run” status of the Development Board.  Selecting an item is the same as clicking on
a button in the System Status window (see Section 4.7).

Run: Activate the “Run” status.
Break: Break the “Run” status.
Single Step: Single-Step the Development Board.
Get Watch: Poll the System Status.
Step Over: Run from a call routine to the next address.

Preferences Menu
The Preferences Menu is used to control the status of different features of the Development Board.

Watch Includes DRAM Selection, IO Sel:

When “Watch Includes DRAM Selection, IO Sel” is selected, the “Registers/Flags”
window, the selected data in the “Data RAM” window, and the selected data in the “I/O
Space” window will update automatically when the monitor detects that the system has
halted.
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Watch is Continuous When Target is Running:

When “Watch is Continuous When Target is Running” is selected, a “Get Watch” (see
System Status Window in section 4.7 for more information on “Get Watch”) is done
every second.  (WARNING:  This may corrupt USB data.)

I/O Space Data Format: From this menu selection two data types are selectable for displaying the I/O Space data
values:  Hex Number Format or Binary Number Format.

Save Project on Exit: When “Save Project on Exit” is selected, a project is automatically saved when exiting.

Development Board Setup:

This menu selection is used to select the Development Board model being used.

Defaults
The Defaults menu contains one menu choice to Restore Default Window Arrangement .  Clicking on Restore
Default Window Arrangement will restore the original arrangement of the window panes.

Communications Menu
The Communication Menu contains menu selections to control the properties of the RS-232 Communications Port to
which the Development Board is connected.

Comm Port: Set the desired RS-232 Communications Port.
Timeout Interval: Set the Timeout Interval for communication failure determination.
Initialize Comm Port: Reinitialize Comm Port to recover from serial communication errors.

Help Menu
Help menu only contains program revision information.

About M8 Monitor: Displays program information dialog window showing program revision and copyright.
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License
The USB Development System Software is licensed for use on a single PC equipped with the USB Development
System Development Board (Part# CY3650, CY3651).  The software may be copied for backup purposes only.


